WeMod fails to install .NET Framework

If you are receiving an error while installing WeMod telling you that the .NET Framework could not be installed, your version of Windows is not supported. The easiest way to fix this issue is to make sure you have all Windows updates installed. You can find a full list of support Windows versions here.

I don’t want to update windows, why can’t you guys just go back to using an older version?

.NET Framework 4.7+ is required for new features in WeMod. As such, we cannot return to an older version. Updating Windows regularly is also critical for the security of your PC as it patches many exploits.

Still need help? Contact Us Contact Us